Скрипт проверки и перезапуска l2tp туннеля в Mikrotik

Тема в разделе "IT-БЕЗОПАСНОСТЬ", создана пользователем Development, 26 дек 2016.

  1. Development

    Development Администратор Команда форума

    Данный скрипт проверяет состояние туннеля, в зависимости от настроек System — Scheduler и в случае есть туннель имеет состояние, отличное от connected, перезапускает его.

    :local tunnelname ("l2tp-out");
    /interface l2tp-client monitor [/interface l2tp-client find name=$tunnelname] once do={
    :if ($status = "connected") do={
    :log info ("VPN work");
    } else={
    /interface l2tp-client disable $tunnelname
    :delay 5;
    /interface l2tp-client enable $tunnelname
    :beep frequency=660 length=100ms;
    :log info ("VPN restart");
    };
    };
     

Поделиться этой страницей